#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b\p{Greek}+"
Local $sString = "Ὁμώνυμα λέγεται Aequivoca dicuntur ὧν ὄνομα μόνον κοινόν, quorum nomen solum commune est" & @CRLF & _
"ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος secundum nomen vero substantiae ratio diversa, οἷον ζῷον ut animal ὅ τε ἄνθρωπος καὶ τὸ γεγραμμένον homo et quod pingitur· " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ἀ·κρασία, -ας, ἡ" & @CRLF & _
"Noun (Fem. 1st Decl.)" & @CRLF & _
"" & @CRLF & _
"Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way." & @CRLF & _
"" & @CRLF & _
"1st Decl. Feminine Noun" & @CRLF & _
"Contracted Uncontracted" & @CRLF & _
"Sg Voc ακρασια ακρασι·α" & @CRLF & _
"Nom" & @CRLF & _
"Acc ακρασιαν[GNT] ακρασι·αν" & @CRLF & _
"Dat ακρασιᾳ ακρασι·ᾳ" & @CRLF & _
"Gen ακρασιας[GNT] ακρασι·ας" & @CRLF & _
"Pl Voc ακρασιαι ακρασι·αι" & @CRLF & _
"Nom" & @CRLF & _
"Acc ακρασιας[GNT] ακρασι·ας" & @CRLF & _
"Dat ακρασιαις[LXX] ακρασι·αις" & @CRLF & _
"Gen ακρασιων ακρασι·ων" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")