re = /\b\p{Greek}+/
str = 'Ὁμώνυμα λέγεται Aequivoca dicuntur ὧν ὄνομα μόνον κοινόν, quorum nomen solum commune est
ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος secundum nomen vero substantiae ratio diversa, οἷον ζῷον ut animal ὅ τε ἄνθρωπος καὶ τὸ γεγραμμένον homo et quod pingitur·
ἀ·κρασία, -ας, ἡ
Noun (Fem. 1st Decl.)
Not all forms below are necessarily attested. Highlighted words may or may not be a match to the GNT or LXX, if another word also inflects the same way.
1st Decl. Feminine Noun
Contracted Uncontracted
Sg Voc ακρασια ακρασι·α
Nom
Acc ακρασιαν[GNT] ακρασι·αν
Dat ακρασιᾳ ακρασι·ᾳ
Gen ακρασιας[GNT] ακρασι·ας
Pl Voc ακρασιαι ακρασι·αι
Nom
Acc ακρασιας[GNT] ακρασι·ας
Dat ακρασιαις[LXX] ακρασι·αις
Gen ακρασιων ακρασι·ων
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end