package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<name>\w\d+)`)
var str = `shop1
shop2
s1
s2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}