$re = '/^(?<name>\w\d+)/m';
$str = 'shop1
shop2
s1
s2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);