using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(\/\d+)(.html)";
string substitution = @"https://yun-sp.com/index.php/vod/play/id$2/sid/1/nid/1.html";
string input = @"https://yun-sp.com/index.php/vod/detail/id/349.html";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}