#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+$| +\(.*\)"
Local $sString = "Argentina" & @CRLF & _
"Australia1" & @CRLF & _
"Bolivia (Plurinational State of)" & @CRLF & _
"China, Hong Kong Special Administrative Region" & @CRLF & _
"Côte d'Ivoire" & @CRLF & _
"Curaçao" & @CRLF & _
"Guinea-Bissau" & @CRLF & _
"Indonesia8"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)