$re = '/\d+$| +\(.*\)/m';
$str = 'Argentina
Australia1
Bolivia (Plurinational State of)
China, Hong Kong Special Administrative Region
Côte d\'Ivoire
Curaçao
Guinea-Bissau
Indonesia8';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;