#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?:\+|00)33[\s.-]{0,3}(?:\(0\)[\s.-]{0,3})?|0)[1-9](?:(?:[\s.-]?\d{2}){4}|\d{2}(?:[\s.-]?\d{3}){2})$"
Local $sString = "French Phone Number Validation." & @CRLF & _
"Accept several kind of format, more or less usual. And refuse incorrect formats." & @CRLF & _
" - Prefix: 0033 / +33 / (0) / 0" & @CRLF & _
" - Number: collapsed / group by 2 / group by 3" & @CRLF & _
" - Separator: space / dot / dash" & @CRLF & _
"" & @CRLF & _
"~ Accepted ~" & @CRLF & _
"0123456789" & @CRLF & _
"01 23 45 67 89" & @CRLF & _
"01.23.45.67.89" & @CRLF & _
"0123 45.67.89" & @CRLF & _
"0033 123-456-789" & @CRLF & _
"0033(0)123456789" & @CRLF & _
"+33-1.23.45.67.89" & @CRLF & _
"+33 - 123 456 789" & @CRLF & _
"+33(0) 123 456 789" & @CRLF & _
"+33 (0)123 45 67 89" & @CRLF & _
"+33 (0)1 2345-6789" & @CRLF & _
"+33(0) - 123456789" & @CRLF & _
"" & @CRLF & _
"~ Rejected ~" & @CRLF & _
"012345678" & @CRLF & _
"01234567890" & @CRLF & _
"0+123456789" & @CRLF & _
"(0)123456789" & @CRLF & _
"01 23 45 67 89" & @CRLF & _
"" & @CRLF & _
"~ Accepted but strange ~" & @CRLF & _
"+33.-.123456789" & @CRLF & _
"+33.-.(0)-.-123456789" & @CRLF & _
"01 23.45-67.89" & @CRLF & _
""
Local $sSubst = "false"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)