$re = '/(^[a-zA-Z0-9.!#$%&\'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+(;)+$)/m';
$str = 'suyog.patil1@gmail.com;
foo@bar.com;
arun@company.com;santosh@company.com;
user1@google.com;user2@google.com;user3@google.com;
[All above 4 values should match, but it is matching only first 2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);