import re
regex = re.compile(r"(^[a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+(;)+$)", flags=re.MULTILINE)
test_str = ("suyog.patil1@gmail.com;\n"
"foo@bar.com;\n"
"arun@company.com;santosh@company.com;\n"
"user1@google.com;user2@google.com;user3@google.com;\n\n"
"[All above 4 values should match, but it is matching only first 2]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")