re = /.Section(\d+(?:\.\d+)?).*\/Jack\/M/m
str = '#Section250342,Main,First/HS/12345/Jack/M,2000 10.00,#Section250322,Main,First/HS/12345/Aaron/N,2000 17.00,#Section250399,Main,First/HS/12345/Jimmy/N,2000 12.00,#Section251234,Main,First/HS/12345/Jack/M,2000 11.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end