package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?\d+(( |-)\d+)*`)
var str = `+1 234 567-8901
44-567-1234 114
1 2345 3566`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}