$re = '/^\+?\d+(( |-)\d+)*/m';
$str = '+1 234 567-8901
44-567-1234 114
1 2345 3566';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);