package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\/`)
var str = `http://localhost:8888/freebies/pg-2/
http://localhost:8888/graphics/pg-2031/
http://localhost:8888/fake/pg-2/s-abcddsagla213414/
http://localhost:8888/fake/pg-2/s-test/
http://localhost:8888/graphics/
http://localhost:8888/premium-pass/
http://localhost:8888/freebies/test/pg-2
http://localhost:8888/freebies/s-test/dladla
http://localhost:8888/freebies/s-a/pg-2
http://localhost:8888/items/test-freebies-item-name/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}