import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(freebies|graphics|websites|ui-kits|premium)\\/|pg-(.*[0-9])|s-(.*)\\/";
final String string = "http://localhost:8888/freebies/pg-2/\n"
+ "http://localhost:8888/graphics/pg-2031/\n"
+ "http://localhost:8888/fake/pg-2/s-abcddsagla213414/\n"
+ "http://localhost:8888/fake/pg-2/s-test/\n"
+ "http://localhost:8888/graphics/\n"
+ "http://localhost:8888/premium-pass/\n"
+ "http://localhost:8888/freebies/test/pg-2\n"
+ "http://localhost:8888/freebies/s-test/dladla\n"
+ "http://localhost:8888/freebies/s-a/pg-2\n"
+ "http://localhost:8888/items/test-freebies-item-name/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}