import re
regex = re.compile(r"(?<!\bof\s)the\b", flags=re.MULTILINE)
test_str = "time of the day word of the day time the day"
subst = "of the"
result = regex.sub(subst, test_str)
if result:
print(result)