re = /(?<!\bof\s)the\b/m
str = 'time of the day word of the day time the day'
subst = 'of the'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result