using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<_KEY_1>[^=\s]+)=(?<_VAL_1>[^=]+)(?=$|\s+[^=\s]+=)";
string input = @"Name=ABC
PLACE=XXX
MESSAGE=PQRS is a valid :CCCC is true
CATEGORY=ZEB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}