const regex = /(?<_KEY_1>[^=\s]+)=(?<_VAL_1>[^=]+)(?=$|\s+[^=\s]+=)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<_KEY_1>[^=\\s]+)=(?<_VAL_1>[^=]+)(?=$|\\s+[^=\\s]+=)', 'gm')
const str = `Name=ABC
PLACE=XXX
MESSAGE=PQRS is a valid :CCCC is true
CATEGORY=ZEB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}