using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z.]*\.)(C\d{1,2})?(B\d{1,2})?([.A-Za-z]*)(42U|48U)?.+-(.+)";
string input = @"This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1
Is.this.Nr.Two.C03B03London.48U.Rack.04-Datacenter4
This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1
This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2
Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}