import Foundation
let pattern = #"^([a-zA-Z.]*\.)(C\d{1,2})?(B\d{1,2})?([.A-Za-z]*)(42U|48U)?.+-(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This.is.Test.Nr.One.C01B01.42U.Rack.08-Datacenter1
Is.this.Nr.Two.C03B03London.48U.Rack.04-Datacenter4
This.Number.Random.C02.Frankfurt.42U.Rack.12-Datacenter1
This.is.Random.Number.C08B01.Zuerich.Rack.01-Datacenter2
Is.this.Nr.Two.B03.London.48U.Rack.04-Datacenter4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)