re = /(?<!WHEN\s+)EMP_ID/m
str = 'SELECT EMP_ID, CASE WHEN EMP_ID > 115 THEN \'greater\' WHEN EMP_ID < 115 THEN \'lower\' END AS TEST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end