using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^def ([a-zA-Z]\w*)\(([^()]*)\):";
string input = @"def Func1(c, v1=None, v2=None, v3=None):
def childFunc(c): # I don't want to catch this
def Func2(c, v1=None, v2=None, v3=None, \
v4=None, v5=None):";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}