$re = '/^def ([a-zA-Z]\w*)\(([^()]*)\):/m';
$str = 'def Func1(c, v1=None, v2=None, v3=None):
def childFunc(c): # I don\'t want to catch this
def Func2(c, v1=None, v2=None, v3=None, \\
v4=None, v5=None):';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);