$re = '/data-(\S+)=\"((?:\\\\.|[^"\\\\])*)"/m';
$str = '<div data-one="true" id="a" data-two="Aaaaa" data-three="01234567" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);