// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)data-(\S+)=\"((?:\\.|[^"\\])*)""#).unwrap();
let string = "<div data-one=\"true\" id=\"a\" data-two=\"Aaaaa\" data-three=\"01234567\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}