#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)data:((?<contenttype>[a-z\-]+\/[a-z\-.]+){1}(;[a-z\-]+\=[a-zA-Z0-9\-]+)?){1}(;filename=(?<passedFileName>[a-zA-Z0-9\-\._]*))(;base64,){1}(?<content>[a-zA-Z0-9\!\$\&\'\,\(\)\*\+\,\;\=\-\.\~\:\@\/\?\%\s]*)_"
Local $sString = "data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC" & @CRLF & _
"_" & @CRLF & _
"" & @CRLF & _
"data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am.txt;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC" & @CRLF & _
"_" & @CRLF & _
"" & @CRLF & _
"data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC" & @CRLF & _
"_" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")