using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data:((?<contenttype>[a-z\-]+\/[a-z\-.]+){1}(;[a-z\-]+\=[a-zA-Z0-9\-]+)?){1}(;filename=(?<passedFileName>[a-zA-Z0-9\-\._]*))(;base64,){1}(?<content>[a-zA-Z0-9\!\$\&\'\,\(\)\*\+\,\;\=\-\.\~\:\@\/\?\%\s]*)_";
string input = @"data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am.txt;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}