const regex = /\b(?:the|on|of)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:the|on|of)\\b', 'gm')
const str = `on long on abc the on`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}