$re = '/\b(?:the|on|of)\b/m';
$str = 'on long on abc the on';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);