package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ABC(?:[BC]*C)?BA`)
var str = `ABCCBA
ABCBCBCBCBBBCCCBCBCBCBCBA
ABCBA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}