$re = '/ABC(?:[BC]*C)?BA/m';
$str = 'ABCCBA
ABCBCBCBCBBBCCCBCBCBCBCBA
ABCBA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);