$re = '/(?<=\s)OF(?=\s)/m';
$str = 'I want to detect " OF " , but does not detect "coffin" or " of course"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);