re = /(?<=\s)OF(?=\s)/m
str = 'I want to detect " OF " , but does not detect "coffin" or " of course"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end