# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\[\ (RUNNING|STOPPED)\ \]
(.+?)
(?:\[Pid:\ (\d+)\]|$)
"""
test_str = ("\n\n"
"I want to extract the words between the two bracket \"blocks\" and also the word in first brackets (RUNNING or STOPPED).\n\n"
"Example (extract the bolded part):\n\n"
"[ RUNNING ] My First Application [Pid: 4194]\n\n"
"[ RUNNING ] Second app (some data) [Pid: 5248]\n\n"
"[ STOPPED ] Logger App\n\n"
"So, as you can see, the [Pid: X] part is optional. I can write the regex as follows:\n\n"
"\\[\\s+(RUNNING|STOPPED)\\s+\\]\\s+([^\\[]+).*\n\n"
"and it will work. But this would fail if App name would contain the '[' character. I tried the following, but it won't work:\n\n"
"\\[\\s+(RUNNING|STOPPED)\\s+\\]\\s+(?!\\[Pid)+.*\n\n"
"My idea was to match any words/characters that are not starting with \"[Pid\", but I guess this would match any words that are not followed by \"[Pid\".\n\n"
"Is there any way to do exactly that: Match any word that is not \"[Pid\", i.e. match the part until first appearing of \"[Pid\" substring?\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.