package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\n(HORIZON-\S+-[A-Z]{1}\d{1}-\d{2})\s+`)
var str = `
HORIZON-CL5-2021-D1-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021
Opening: 15 Apr 2021
Deadline(s): 07 Sep 2021
HORIZON-CL5-2022-D1-01-two-stage
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2022
Opening: 04 Nov 2021
Deadline(s): 15 Feb 2022 (First Stage), 07 Sep 2022 (Second Stage)
HORIZON-CL5-2021-D2-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021 2022
Opening: 15 Apr 2021
Deadline(s): 19 Oct 2021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}