use strict;
my $str = '
HORIZON-CL5-2021-D1-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021
Opening: 15 Apr 2021
Deadline(s): 07 Sep 2021
HORIZON-CL5-2022-D1-01-two-stage
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2022
Opening: 04 Nov 2021
Deadline(s): 15 Feb 2022 (First Stage), 07 Sep 2022 (Second Stage)
HORIZON-CL5-2021-D2-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021 2022
Opening: 15 Apr 2021
Deadline(s): 19 Oct 2021';
my $regex = qr/\n(HORIZON-\S+-[A-Z]{1}\d{1}-\d{2})\s+/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}