import re
regex = re.compile(r"^(?:\s*\d+\s+Secs\s*\(\s*(\d+(?:\.\d+)?%)\)){3}", flags=re.MULTILINE)
test_str = ("5 Secs ( 22.3463%) 60 Secs ( 25.677%) 300 Secs ( 21.3522%)\n"
" 5 Secs ( 13.6713%) 60 Secs ( 15.3520%) 300 Secs ( 15.9640%)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")