package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\S[\x{0400}-\x{04FF}a-zA-Z\s]{2,128}$`)
var str = `Вася dsdsd sds `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}