import re
regex = re.compile(r"^\S[\x{0400}-\x{04FF}a-zA-Z\s]{2,128}$", flags=re.UNICODE | re.IGNORECASE)
test_str = "Вася dsdsd sds "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")