using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+(?:-\w+)*)=(?|""((?:[^""]+|(?<=\\)"")++)""|([^""\s]+))";
string input = @"add name=100YER on-login="":do {:put \""a\"";} on-error={};"" rate-limit=256k/512k
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}