re = /(\w+(?:-\w+)*)=(?|"((?:[^"]+|(?<=\\)")++)"|([^"\s]+))/m
str = 'add name=100YER on-login=":do {:put \\"a\\";} on-error={};" rate-limit=256k/512k
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end