import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*(?<=\\bobj)\\s*\\R)[\\s\\S]*?\\/Form[\\s\\S]*?^(stream\\s*^)[\\s\\S]*?^(endstream\\s+endobj)";
final String string = "40 0 obj \n"
+ "<<\n"
+ "/PieceInfo \n"
+ "/Subtype /Form\n"
+ "/Resources \n"
+ "<<\n"
+ "/Font \n"
+ "<<\n"
+ "/Fm1 35 0 R\n"
+ ">>\n"
+ ">>\n"
+ "/Type /XObject\n"
+ "/BBox [0 -22.5 131.05 0]\n"
+ "/Length 601\n"
+ "/Matrix [1 0 0 1 0 0]\n"
+ ">>\n"
+ "stream\n"
+ " . . .\n"
+ " A bunch of compressed gibberish here\n"
+ " . . .\n"
+ "endstream \n"
+ "endobj";
final String subst = "\\1\\2\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}