const regex = /(^.*(?<=\bobj)\s*\R)[\s\S]*?\/Form[\s\S]*?^(stream\s*^)[\s\S]*?^(endstream\s+endobj)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*(?<=\\bobj)\\s*\\R)[\\s\\S]*?\\\/Form[\\s\\S]*?^(stream\\s*^)[\\s\\S]*?^(endstream\\s+endobj)', 'gm')
const str = `40 0 obj
<<
/PieceInfo
/Subtype /Form
/Resources
<<
/Font
<<
/Fm1 35 0 R
>>
>>
/Type /XObject
/BBox [0 -22.5 131.05 0]
/Length 601
/Matrix [1 0 0 1 0 0]
>>
stream
. . .
A bunch of compressed gibberish here
. . .
endstream
endobj`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);