package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<myTag)([\s\S]*?)(>)([\s\S]*?)(<\/myTag>)`)
var str = `<myTag value="One" value="Two">SomeContentHere</myTag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}