$re = '/(<myTag)([\s\S]*?)(>)([\s\S]*?)(<\/myTag>)/m';
$str = '<myTag value="One" value="Two">SomeContentHere</myTag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);