import re
regex = re.compile(r"^([a-zA-z]{3})(\d{4})(?:\d{2})?(_00)([0-7])(.*)$", flags=re.MULTILINE)
test_str = ("HTH0919_001-werelwkre;lkj\n"
"HTH0919_007_dgfsdfs\n"
"HTH0919_008\n"
"HTH0919_009\n"
"HtH0919_010\n"
"HTH0919_097\n"
"HTH0919_098\n"
"HTH0919_099\n"
"HTH0919_100\n"
"HTH0919_111\n"
"HTH0919_101\n"
"HTH0919_899\n"
"HTH123456_020\n\n\n\n"
"^([a-zA-z]{3})(\\d{4})(?:\\d{2})?(_00)([0-7])(.*)$\n\n"
"^([a-zA-z]{3})(\\d{4})(?:\\d{2})?(_0)(?!98|99)(08|09|[1-9][0-9])(.*)$\n\n"
"^([a-zA-z]{3})(\\d{4})(?:\\d{2})?_(098|099|[1-9][0-9][0-9])(.*)$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")