import Foundation
let pattern = #"^([a-zA-z]{3})(\d{4})(?:\d{2})?(_00)([0-7])(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
HTH0919_001-werelwkre;lkj
HTH0919_007_dgfsdfs
HTH0919_008
HTH0919_009
HtH0919_010
HTH0919_097
HTH0919_098
HTH0919_099
HTH0919_100
HTH0919_111
HTH0919_101
HTH0919_899
HTH123456_020
^([a-zA-z]{3})(\d{4})(?:\d{2})?(_00)([0-7])(.*)$
^([a-zA-z]{3})(\d{4})(?:\d{2})?(_0)(?!98|99)(08|09|[1-9][0-9])(.*)$
^([a-zA-z]{3})(\d{4})(?:\d{2})?_(098|099|[1-9][0-9][0-9])(.*)$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)