use strict;
my $str = '919012345678';
my $regex = qr/[+0-9](?=[0-9]{4})/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";