$re = '/[+0-9](?=[0-9]{4})/m';
$str = '919012345678';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;